
Sync-N-Link X
Sync-N-Link X takes away the time-consuming chore of synchronizing dailies or 
rushes by batch processing an Event of clips with matching SMPTE/EBU Timecode.

Contents:

Preparing Clips for Syncing
1. Import the video files and audio files into a new Event in Final Cut Pro X. 

Video and audio files must have jam-synced Timecode. 
2. If you have multiple days of clips in your Event, confirm the Content Created 

dates for the clips by choosing View > Event Browser > Group Clips By > 
Content Created. Sync-N-Link X can use the Content Created date to find 
the clips recorded on the same day. The content created date of clips can be 
changed by selecting a batch of clips and choosing Modify > Adjust 
Content Created Date and Time...

3. Optionally Apply Custom Name to rename the clips.
4. Optionally add Camera Angle names. Multicams are created with video 

angles ordered by Camera Angle or Name, followed by audio angle(s).
5. Optionally create a Project with a custom resolution (frame size) to be used 

for synchronized or multicam clips (see Preferences).
6. Optionally apply video adjustments, such as spacial conform and LUTs.
7. Optionally change the audio configuration or disable unwanted audio 

channels in the audio clips. This can be done as a batch by selecting all the 
audio clips in the Event.

8. Optionally add keywords, favorites, rejected or markers. Any keywords/
ratings/markers on the video and audio clips will pass through to the 
synchronized clips and multicams made by Sync-N-Link X.
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Syncing Event(s) of Clips
1. Select one or more Events. Choose the File menu and select Export XML...  

IMPORTANT: Media must be fully imported before exporting XML. You can 
view the import progress in the Background Tasks window.

2. If you have a single day of clips choose the Extended Metadata View from 
the popup menu; otherwise choose the Sync-N-Link X Metadata View from 
the popup menu (see About transferring metadata from clips to 
Synchronized clips for more information about installing the Metadata View). 
Name and save the Event XML file. All clips should be online before 
exporting XML. 

3. In Sync-N-Link X, click the Open XML... button and select the exported 
Event XML file.  
Tip: Final Cut Pro 10.3 supports drag-and-drop instead of exporting XML. 
An alternative to these first 3 steps is to choose the Sync-N-Link X Metadata 
View from the popup menu in the Inspector, then drag the Event and drop it 
onto the Sync-N-Link X window or its icon in the Dock. (A progress bar in 
Final Cut Pro X shows the XML being generated in the background.)

4. Choose the options you want for your synchronized clips:
• Set the popup menu to choose whether to have the synchronized clips 

named after the video or audio clip names or both.
• Set the popup menu to choose whether to have notes and metadata from 

either the video or audio clip or both added to the synchronized clip.
• You can also choose how the synced clips are trimmed. Trim clips to 

common video and audio duration will create a synchronized clips 
trimmed to the area where there is both video and audio; No Trim (plus 
rejected ranges) will not trim the clips but will add Rejected ranges to 
the areas with video only or audio only.

• In cases where the video and audio are out of sync by a few frames, you 
can apply an adjustment to the audio offset. Enter the offset value into 
the Adjust audio offset entry box.

• Optionally choose to Make Multicams: choose and to make synchronized 
clips as well as multicams where there are multiple video angles; choose 
or to make multicams where there are multiple video angles and only 
synchronized clips when there is a single video angle; choose instead of 
to make no synchronized clips but instead make multicams when there 
are single or multiple video angles.

• Optionally choose to Make wrapped Video clips at a different frame 
size. This will create a synchronized clip containing a single video clip, 
but the synchronized clip’s “wrapper” will use the Project’s frame size 
and Spatial Conform Type (see Preferences).

• Optionally choose to Use Track Names from audio iXML for Subrole 
Names (if iXML is available in the WAV clips) or edit the subrole names 
for each audio track. For example tracks A7 and A8 may be renamed 
“Mixdown” so that in Final Cut Pro X they will have the role Dialogue and 



the subrole Mixdown. (See About using iXML information from WAV files 
and Controlling Audio Track Playback with Roles.)

• Optionally choose to Use Subrole Names for audio component names 
to have the audio components named after the track’s subrole.

5. Click the Sync Clips... button to start the process of finding matching audio. 
Sync-N-Link X will tell you to how many clips it found matching audio for, 
how many it didn’t, how many multicams were made, and gives you the 
option to save a report of the details (see About the Sync-N-Link X Report).

6. In the Save dialog, name your XML file and choose a place to save it.
7. In Final Cut Pro X, choose the File menu and from the Import submenu, 

select XML... Select the XML file saved out of Sync-N-Link X. (Or use the 
Import automatically after saving checkbox to import the file for you.) 

Final Cut Pro 10.3 can update the Event: you’ll get a dialog saying “Application Sync-
N-Link X sent an XML document that is about to replace existing items with 
matching names”. Click the Replace button to update the original Event with 
synchronized clips and multicam clips. For earlier versions the synced clips and 
multicams will be imported into a new Event; this will also happen if you have renamed 
your FCPX 10.3 .fcpxml file in the Save dialog. 
Audio subroles and component names are added to all clips. Multicam clips will be 
tagged with the keyword “Multicam”; synced clips will be tagged with the keyword 
“Synced” covering the range where there is both video and audio, and audio 
components in the synchronized clips are tagged with subroles. Camera audio is 
disabled in the inspector. The markers, keywords, ratings and metadata from the 
original clips are added to the synced clips, and notes in the video and audio clips’ 
Notes fields are joined and added to the synced clip's or multicam’s Notes field.
Clips that were not used for synced clips are tagged with the keyword “Not Synced”.
More control over frame sizes, spatial conform, rendering codec and anamorphic 
footage is available in the Preferences (see Preferences).
NOTE: If you get an error message from Sync-N-Link X or Final Cut Pro, please email 
the problem XML file to SyncNLink@AssistedEditing.com.

mailto:SyncNLink@assistedediting.com?subject=


About using iXML information from WAV files
If the WAV files have iXML track names Sync-N-Link X will enable the checkbox Use 
audio iXML track names for Subrole Names. If this is on then the audio components 
will be tagged with subroles according to the iXML track/microphone names in the 
WAV file. Each WAV has its own iXML, so if during a shoot the audio had to change 
channel assignments for a person or character, as long as the new channel 
assignments are given the updated microphone names, then the subroles will be 
applied correctly to the channels for that clip.
You can still set the camera audio's subrole name, but the other tracks will be disabled 
if you're choosing to use the iXML track names.
The role names for the audio components (except for the camera audio) are dimmed 
because they are being defined from the iXML on a clip-by-clip basis. If you don't want 
to use the iXML track/microphone names, you can turn off the Use Track Names from 
audio for Subrole Names checkbox to re-enable the subroles naming table. The 
disadvantage is that these names will be applied globally regardless of any changes to 
track assignment, whereas iXML track names can change between clips.
Circled and Wild Track metadata from iXML, if available, are added as keywords to the 
synced clips.

Multicam workflows
The multicam clips created by Sync-N-Link X from an Event of clips will have one or 
more angles of video clips and one or more angles of audio clips, synced to timecode.
Alternatively it’s possible to make multicams with synchronized clips on each angle by 
sending Sync-N-Link X an Event of previously synced clips. The workflow is:

• Export XML of the Event containing video and audio clips.
• Process the XML through Sync-N-Link X and back into Final Cut Pro X 

with the Make Multicams checkbox ‘off’ so only synced clips are created.
• Optionally review and adjust the sync points of the synchronized clips in 

Final Cut Pro X.
• Export XML of the new Event containing synchronized clips.
• Process the XML through Sync-N-Link X and back into Final Cut Pro X 

with the Make Multicams checkbox ‘on’ so that multicams are created 
with a synchronized clip on each angle, synced to timecode.

The angles in a multicam clip are named using metadata in the XML from the original 
clips or synchronized clips. If Camera Angle metadata is available in the XML, that will 
be used for multicam angle names; if not, Camera Name metadata will be used; if 
neither of those are in the XML the multicam angles are given the clip names. For more 
information about getting Camera Angle or Camera Name metadata into the exported 
XML, see About transferring metadata from clips to Synchronized and Multicam clips.



Preferences
The Sync-N-Link X Preferences window allows 
you to set Spatial Conform Type, 
Synchronized clip video resolution, Multicam 
clip video resolution, Multicam rendering 
codec, and to Override anamorphic formats.
Spatial Conform is applied to the video clips 
inside a synchronized clip container and in a 
multicam angle. For example, to create 
synchronized or multicam clips with a custom 
resolution, add a Project to your Event, set the 
frame size and frame rate, and include the 
Project in your exported XML. In Sync-N-Link X, 
change the preferences to Spatial Conform Type 
None and video resolutions to Match the 
Project frame size. 
Each version of Final Cut Pro X supports some 
anamorphic formats for synchronized clips, but 
newer anamorphic formats might create 
letterboxed or squeezed images in synced clips. 
As a work-around, Sync-N-Link X can create a 
square-pixel format for the synced clips that’s 
appropriate for the anamorphic format. (Un-
synced clips retain the original anamorphic 
format.) To enable this feature, turn the 
Override anamorphic formats checkbox “on”.
By default Sync-N-Link X will add “V:” at the 
start of notes from video clips and “A:” at the 
start of notes from audio clips. You can override 
this by entering your own notes prefixes in the 
Video: and Audio: fields, or leave the fields blank 
to have no prefixes added to the notes.
By default Sync-N-Link X will add “ - Synced” to the event names in the XML file, which 
will create new events in your Library. For 10.3 and later, if you choose to Keep 
original Event name, Final Cut Pro X will add the new synced clips and multicams into 
the original events their video clips came from.



About transferring metadata from clips to 
Synchronized and Multicam clips
Metadata in the original clips, such as Content Created, Reel, Scene, Take, Camera 
Angle, Camera Name and Camera LUT, can be included in the exported XML and 
transferred to the synchronized clips and multicams created by Sync-N-Link X. The 
easiest way to include this metadata is to install the Sync-N-Link X Metadata View and 
select it in the Metadata Views popup menu when exporting XML. 

1. In Sync-N-Link X, choose the Help menu and select Install Metadata View.
2. Quit Final Cut Pro X (if it is running) and run Final Cut Pro X. 

The Sync-N-Link X metadata view is available in the Info panel of the Inspector, and in 
the Metadata View popup menu of the Export XML dialog.
See the tutorial at www.fcp.co/final-cut-pro/tutorials/1542-the-power-of-metadata-
views-in-final-cut-pro-x-by-philip-hodgetts for more information about metadata 
views.

About the Sync-N-Link X Report
Sync-N-Link X can create a detailed report about the clips it was able to sync and 
those that weren’t synced. You can save this report as a text file by clicking the Save 
Report button. Sync-N-Link X will save the report text file and then prompt you to 
save the XML file.
The top of the report summarizes how many video clips had matching audio found for 
them, and how many video clips did not have matching audio. 
Underneath the summary are listed the details of the video clips that were synced with 
audio. Example:

"A013_C002_0803FG_H" was synced with "Z004002.WAV"
Lastly is a list of video clips that were not synced to audio. If there was no audio 
captured during a take, Sync-N-Link X will report that it was unable to find audio for 
the video clip. Example:

Could not find audio for "A004_C001_0803DV_H"

Controlling Audio Playback with Roles
If the tracks in the WAV file have been labelled on set, Sync-N-Link X will give you the 
option of using those labels for the Dialog subroles, along with the subrole name you 
entered for the Camera track. If not, you can assign names for the audio and camera 
audio tracks in the Subrole table.
During editorial use Roles to control the audio tracks you want to work with. See 
help.apple.com/finalcutpro/mac/#verb71cbcbe for an overview of Roles.

1. Choose the View menu and from the Timeline Index submenu select Roles.
2. Deselect the checkboxes next to the subroles you don’t want to hear.

http://www.fcp.co/final-cut-pro/tutorials/1542-the-power-of-metadata-views-in-final-cut-pro-x-by-philip-hodgetts
http://www.fcp.co/final-cut-pro/tutorials/1542-the-power-of-metadata-views-in-final-cut-pro-x-by-philip-hodgetts
http://www.fcp.co/final-cut-pro/tutorials/1542-the-power-of-metadata-views-in-final-cut-pro-x-by-philip-hodgetts
http://help.apple.com/finalcutpro/mac/#verb71cbcbe


About Video Frame Sizes and Synchronized Clips
In Final Cut Pro 10.0.9 and earlier (which does not support custom frame sizes), 
synchronized clips are a type of compound clip so their video resolution has to be one 
of the standard frame sizes supported by Projects and Compound Clips. If you are 
creating proxies outside of Final Cut Pro X it is possible to create them with a non-
standard frame size. For non-standard video frame sizes, Sync-N-Link X will choose a 
synchronized clip resolution with the largest frame size that is smaller than the proxy's 
width, and chooses either an exact match for pixel aspect or whatever is closest. For 
example, with 2400x1350 proxies Sync-N-Link X creates synchronized clips at 
2048x1152.
This does not apply to Final Cut Pro 10.1. But for 10.0.9 and earlier, proxy clips should 
be transcoded into video frame sizes supported by your version of Final Cut Pro X:

• 640x480,

• 720x480,

• 720x486,

• 720x576,

• 960x540,

• 960x720,

• 1280x720,

• 1280x1080,

• 1440x1080,

• 1920x1080,

• 2048x1024,

• 2048x1080,

• 2048x1152,

• 2048x1536,

• 2048x1556,

• 3840x2160,

• 4096x2048,

• 4096x2160,

• 4096x2304,

• 4096x3112,

• 5120x2160,

• 5120x2560,

• 5120x2700.
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